myeclipse 新建web project java EE 5.0以上不能选jstl support

江山如画 问题 369

2019111305592653

如下图所示:myeclipse 10.0 新建web project时, java EE 5.0以上不能选jstl support。

难道JAVAEE 5.0以上不支持JSTL了吗?

sun公司 在 javaEE 1.4 里面没写 jstl 的相关代码, 所以需要选jstl support,好把JSTL libraries添加到web-inf/lib下。

从javaEE 5.0 之后已经支持 jstl 了,不需要再选jstl support。也就是你建web project 时,j2EE Specification Level 选择了java EE 5.0以上版本,本身就已经支持JSTL了。

回复

我来回复
  • 暂无回复内容